MacOS tips

Hide a user account in MacOS

  1. https://support.apple.com/en-us/HT203998
  2. https://www.reddit.com/r/macsysadmin/comments/emxph7/catalina_create_a_hidden_user/
  3. https://github.com/gregneagle/pycreateuserpkg
  4. Creating user account
    1. https://apple.stackexchange.com/questions/226073/how-do-i-create-user-accounts-from-the-terminal-in-mac-os-x-10-11
    2. https://sterlingit.com.au/how-to-create-a-user-or-admin-user-in-osx-apple-mac-via-terminal-commands-in-9-simple-steps/
    3. https://mackeeper.com/blog/post/356-using-various-types-of-user-accounts-on-mac/

 

Find files created or modified by an installer

  1. http://hints.macworld.com/article.php?story=20091223115101622

 

Take backup of startup entries

I’d take a before and after snapshot to identify what was added.

# [backup startup locations]
for loc in /Library/StartupItems /Library/LaunchDaemons /System/Library/LaunchDaemons ${HOME}/Library/LaunchAgents /Library/LaunchAgents/ /System/Library/LaunchAgents/; do
 echo $loc
 folder=`echo $loc | tr / _`
 mkdir ${folder}
 sudo cp -r ${loc} ${folder}
done


# [command output]
for cmd in "crontab -l" "kextstat" "defaults read com.apple.loginwindow LoginHook" "defaults read com.apple.loginwindow LogoutHook"; do
 echo $cmd
 cmd_file=`echo $cmd | tr " /" _`
 echo ${cmd_file}
 sudo ${cmd} > "${cmd_file}.out" 2>&1
done

 

 

You may also like...

Leave a Reply

Your email address will not be published. Required fields are marked *